#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(https?:\/\/)([a-zA-Z0-9]+)\.(example.com\/product\/)([a-zA-Z0-9]+)(\/shop)\/?"
Local $sString = "http://a.example.com/product/table/shop/" & @CRLF & _
"http://b.example.com/product/shoe/"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)