import re
regex = re.compile(r"(https?:\/\/)([a-zA-Z0-9]+)\.(example.com\/product\/)([a-zA-Z0-9]+)(\/shop)\/?")
test_str = ("http://a.example.com/product/table/shop/\n"
"http://b.example.com/product/shoe/")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)