import Foundation
let pattern = #"(https?:\/\/)([a-zA-Z0-9]+)\.(example.com\/product\/)([a-zA-Z0-9]+)(\/shop)\/?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://a.example.com/product/table/shop/
http://b.example.com/product/shoe/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)