use strict;
my $str = 'http://a.example.com/product/table/shop/
http://b.example.com/product/shoe/';
my $regex = qr/(https?:\/\/)([a-zA-Z0-9]+)\.(example.com\/product\/)([a-zA-Z0-9]+)(\/shop)\/?/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";