#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?P<Date>(?:(?:(?P<Day>\d{1,2})[ /\.]+)?(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December|\d{1,2})[ /\.]+)?(?P<Year>\d{4}|(?(Month)\d{2}|(?P<Age>\d{2}))))\b"
Local $sString = "a 15/01/2012" & @CRLF & _
"13/54" & @CRLF & _
"34"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")