re = /(?P<Date>(?:(?:(?P<Day>\d{1,2})[ \/\.]+)?(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December|\d{1,2})[ \/\.]+)?(?P<Year>\d{4}|(?(Month)\d{2}|(?P<Age>\d{2}))))\b/mi
str = 'a 15/01/2012
13/54
34'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end