import re
regex = re.compile(r"(?P<Date>(?:(?:(?P<Day>\d{1,2})[ /\.]+)?(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December|\d{1,2})[ /\.]+)?(?P<Year>\d{4}|(?(Month)\d{2}|(?P<Age>\d{2}))))\b", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("a 15/01/2012\n"
"13/54\n"
"34")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")