import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<Date>(?:(?:(?P<Day>\\d{1,2})[ /\\.]+)?(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December|\\d{1,2})[ /\\.]+)?(?P<Year>\\d{4}|(?(Month)\\d{2}|(?P<Age>\\d{2}))))\\b";
final String string = "a 15/01/2012\n"
+ "13/54\n"
+ "34";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}