using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<Date>(?:(?:(?P<Day>\d{1,2})[ /\.]+)?(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December|\d{1,2})[ /\.]+)?(?P<Year>\d{4}|(?(Month)\d{2}|(?P<Age>\d{2}))))\b";
string input = @"a 15/01/2012
13/54
34";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}