use strict;
my $str = 'a 15/01/2012
13/54
34';
my $regex = qr/(?P<Date>(?:(?:(?P<Day>\d{1,2})[ /\.]+)?(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December|\d{1,2})[ /\.]+)?(?P<Year>\d{4}|(?(Month)\d{2}|(?P<Age>\d{2}))))\b/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}