using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|(?<=\s)) # delimitador inicial
[+-]?(?:\d+\.\d+|\d+\.|\.\d+|\d+) # valores con o sin signo
(?:e[+-]?\d+)? # parte exponencial
(?=\s) # delimitador final";
string input = @"Hace coincidir para el sistema de numeración decimal valores numéricos aislados, es decir, valores no unidos a otros caracteres.
test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a
22e22 22e+22 +22e22 +22e+22
22.22 22. .22
22.e22 22.e+22 22.22e22 22.22e+22 .22e22 .22e+22
88e 88e+ e88 e+88 88e88.";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}