import Foundation
let pattern = ##"""
(?:^|(?<=\s)) # delimitador inicial
[+-]?(?:\d+\.\d+|\d+\.|\.\d+|\d+) # valores con o sin signo
(?:e[+-]?\d+)? # parte exponencial
(?=\s) # delimitador final
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
Hace coincidir para el sistema de numeración decimal valores numéricos aislados, es decir, valores no unidos a otros caracteres.
test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a
22e22 22e+22 +22e22 +22e+22
22.22 22. .22
22.e22 22.e+22 22.22e22 22.22e+22 .22e22 .22e+22
88e 88e+ e88 e+88 88e88.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)