import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<=\\s)) # delimitador inicial\n"
+ "[+-]?(?:\\d+\\.\\d+|\\d+\\.|\\.\\d+|\\d+) # valores con o sin signo\n"
+ "(?:e[+-]?\\d+)? # parte exponencial\n"
+ "(?=\\s) # delimitador final";
final String string = "Hace coincidir para el sistema de numeración decimal valores numéricos aislados, es decir, valores no unidos a otros caracteres.\n"
+ "test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a\n"
+ "22e22 22e+22 +22e22 +22e+22\n"
+ "22.22 22. .22\n"
+ "22.e22 22.e+22 22.22e22 22.22e+22 .22e22 .22e+22\n"
+ "88e 88e+ e88 e+88 88e88.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}