use strict;
my $str = 'Hace coincidir para el sistema de numeración decimal valores numéricos aislados, es decir, valores no unidos a otros caracteres.
test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a
22e22 22e+22 +22e22 +22e+22
22.22 22. .22
22.e22 22.e+22 22.22e22 22.22e+22 .22e22 .22e+22
88e 88e+ e88 e+88 88e88.';
my $regex = qr/(?:^|(?<=\s)) # delimitador inicial
[+-]?(?:\d+\.\d+|\d+\.|\.\d+|\d+) # valores con o sin signo
(?:e[+-]?\d+)? # parte exponencial
(?=\s) # delimitador final/ixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}