package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:na|(?:t|s|k|x)(?:a|(?:i|e|u|o)(?:n|(?:t|s|k|x)(?:a|(?:i|e|u|o)))))`)
var str = `n
na
sa
xa
ti
tin
ten
tun
ton
tan
kis
kisa
kise`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}