import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:na|(?:t|s|k|x)(?:a|(?:i|e|u|o)(?:n|(?:t|s|k|x)(?:a|(?:i|e|u|o)))))";
final String string = "n\n"
+ "na\n"
+ "sa\n"
+ "xa\n\n"
+ "ti\n"
+ "tin\n"
+ "ten\n"
+ "tun\n"
+ "ton\n"
+ "tan\n\n"
+ "kis\n"
+ "kisa\n"
+ "kise";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}