$re = '/(?:na|(?:t|s|k|x)(?:a|(?:i|e|u|o)(?:n|(?:t|s|k|x)(?:a|(?:i|e|u|o)))))/m';
$str = 'n
na
sa
xa
ti
tin
ten
tun
ton
tan
kis
kisa
kise';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);