#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)The (?:(?!no|never|not).){0,50}? has not fully complied with its obligations under the Prior Undertaking"
Local $sString = "The City has not fully complied with its obligations under the Prior Undertaking" & @CRLF & _
"The School District has not fully complied with its obligations under the Prior Undertaking" & @CRLF & _
"The District has not fully complied with its obligations under the Prior Undertaking" & @CRLF & _
"" & @CRLF & _
"The not District has not fully complied with its obligations under the Prior Undertaking"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")