use strict;
my $str = 'The City has not fully complied with its obligations under the Prior Undertaking
The School District has not fully complied with its obligations under the Prior Undertaking
The District has not fully complied with its obligations under the Prior Undertaking
The not District has not fully complied with its obligations under the Prior Undertaking';
my $regex = qr/The (?:(?!no|never|not).){0,50}? has not fully complied with its obligations under the Prior Undertaking/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}