const regex = /The (?:(?!no|never|not).){0,50}? has not fully complied with its obligations under the Prior Undertaking/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('The (?:(?!no|never|not).){0,50}? has not fully complied with its obligations under the Prior Undertaking', 'gmi')
const str = `The City has not fully complied with its obligations under the Prior Undertaking
The School District has not fully complied with its obligations under the Prior Undertaking
The District has not fully complied with its obligations under the Prior Undertaking
The not District has not fully complied with its obligations under the Prior Undertaking`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}