re = /The (?:(?!no|never|not).){0,50}? has not fully complied with its obligations under the Prior Undertaking/mi
str = 'The City has not fully complied with its obligations under the Prior Undertaking
The School District has not fully complied with its obligations under the Prior Undertaking
The District has not fully complied with its obligations under the Prior Undertaking
The not District has not fully complied with its obligations under the Prior Undertaking'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end