import Foundation
let pattern = #"The (?:(?!no|never|not).){0,50}? has not fully complied with its obligations under the Prior Undertaking"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
The City has not fully complied with its obligations under the Prior Undertaking
The School District has not fully complied with its obligations under the Prior Undertaking
The District has not fully complied with its obligations under the Prior Undertaking
The not District has not fully complied with its obligations under the Prior Undertaking
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)