#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-z]+? ([^-]+)-([^-]+?) ([a-z ]+)$"
Local $sString = "translate from-to word for translate" & @CRLF & _
"translate dari-ke dari-ke word for translate" & @CRLF & _
"translate clé-solution word for translate" & @CRLF & _
"translate goodbye-さようなら word for translate"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")