const regex = /^[a-z]+? ([^-]+)-([^-]+?) ([a-z ]+)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]+? ([^-]+)-([^-]+?) ([a-z ]+)$', 'gmi')
const str = `translate from-to word for translate
translate dari-ke dari-ke word for translate
translate clé-solution word for translate
translate goodbye-さようなら word for translate`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}