re = /^[a-z]+? ([^-]+)-([^-]+?) ([a-z ]+)$/mi
str = 'translate from-to word for translate
translate dari-ke dari-ke word for translate
translate clé-solution word for translate
translate goodbye-さようなら word for translate'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end