$re = '/^[a-z]+? ([^-]+)-([^-]+?) ([a-z ]+)$/mi';
$str = 'translate from-to word for translate
translate dari-ke dari-ke word for translate
translate clé-solution word for translate
translate goodbye-さようなら word for translate';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);