// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[a-z]+? ([^-]+)-([^-]+?) ([a-z ]+)$").unwrap();
let string = "translate from-to word for translate
translate dari-ke dari-ke word for translate
translate clé-solution word for translate
translate goodbye-さようなら word for translate";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}