package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[a-z]+? ([^-]+)-([^-]+?) ([a-z ]+)$`)
var str = `translate from-to word for translate
translate dari-ke dari-ke word for translate
translate clé-solution word for translate
translate goodbye-さようなら word for translate`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}