import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\s\\n]*(^\\s*)[^\\{\\};]*\\{)";
final String string = "\n"
+ "public class Main {\n\n"
+ " class innerClass {\n\n"
+ " int a;\n"
+ " int b;\n\n"
+ " @Override\n"
+ " private int goo() {\n\n"
+ " }\n"
+ " }\n\n"
+ " String a;\n\n"
+ " public static void main (String[] args) {\n"
+ " // blablabla\n"
+ " }\n\n"
+ " @Override\n"
+ " public int foo(int a) {\n\n"
+ " }\n"
+ "}";
final String subst = "$2/***/$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}