$re = '/^([\s\n]*(^\s*)[^{};]*\{)/m';
$str = '
public class Main {
class innerClass {
int a;
int b;
@Override
private int goo() {
}
}
String a;
public static void main (String[] args) {
// blablabla
}
@Override
public int foo(int a) {
}
}';
$subst = "$2/***/$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;