const regex = /^([\s\n]*(^\s*)[^{};]*\{)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\s\\n]*(^\\s*)[^{};]*\\{)', 'gm')
const str = `
public class Main {
class innerClass {
int a;
int b;
@Override
private int goo() {
}
}
String a;
public static void main (String[] args) {
// blablabla
}
@Override
public int foo(int a) {
}
}`;
const subst = `$2/***/$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);