#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\[(?:[^][]++|\g<1>)*])+$"
Local $sString = "test 1" & @CRLF & _
"[test 2]" & @CRLF & _
"[test] 3" & @CRLF & _
"test [4]" & @CRLF & _
"[test][5]" & @CRLF & _
"[te[st]6][te[xt]7]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")