import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\[(?:[^][]++|\\g<1>)*])+$";
final String string = "test 1\n"
+ "[test 2]\n"
+ "[test] 3\n"
+ "test [4]\n"
+ "[test][5]\n"
+ "[te[st]6][te[xt]7]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}