re = /^(\[(?:[^][]++|\g<1>)*])+$/m
str = 'test 1
[test 2]
[test] 3
test [4]
[test][5]
[te[st]6][te[xt]7]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end