$re = '/^(\[(?:[^][]++|\g<1>)*])+$/m';
$str = 'test 1
[test 2]
[test] 3
test [4]
[test][5]
[te[st]6][te[xt]7]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);