const regex = /^(\[(?:[^][]++|\g<1>)*])+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\[(?:[^][]++|\\g<1>)*])+$', 'gm')
const str = `test 1
[test 2]
[test] 3
test [4]
[test][5]
[te[st]6][te[xt]7]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}