using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\[(?:[^][]++|\g<1>)*])+$";
string input = @"test 1
[test 2]
[test] 3
test [4]
[test][5]
[te[st]6][te[xt]7]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}