#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*?([^-]..|.[^6].|..[^X])$"
Local $sString = "fhas bdhs -6X" & @CRLF & _
"dfskj sd -5X" & @CRLF & _
"sdjfh djs -" & @CRLF & _
"f dsjfsd-6X" & @CRLF & _
"dsfj iäds -6X eiofjw"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")