use strict;
my $str = 'fhas bdhs -6X
dfskj sd -5X
sdjfh djs -
f dsjfsd-6X
dsfj iäds -6X eiofjw';
my $regex = qr/.*?([^-]..|.[^6].|..[^X])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}