const regex = /.*?([^-]..|.[^6].|..[^X])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?([^-]..|.[^6].|..[^X])$', 'gm')
const str = `fhas bdhs -6X
dfskj sd -5X
sdjfh djs -
f dsjfsd-6X
dsfj iäds -6X eiofjw`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}