$re = '/.*?([^-]..|.[^6].|..[^X])$/m';
$str = 'fhas bdhs -6X
dfskj sd -5X
sdjfh djs -
f dsjfsd-6X
dsfj iäds -6X eiofjw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);