package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?([^-]..|.[^6].|..[^X])$`)
var str = `fhas bdhs -6X
dfskj sd -5X
sdjfh djs -
f dsjfsd-6X
dsfj iäds -6X eiofjw`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}