using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?([^-]..|.[^6].|..[^X])$";
string input = @"fhas bdhs -6X
dfskj sd -5X
sdjfh djs -
f dsjfsd-6X
dsfj iäds -6X eiofjw";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}