#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:BRAND3|BRAND4)[^\n]+(\n|$)"
Local $sString = "Brand,Item Number,UPC,Description,RRP, Stock Level" & @CRLF & _
"BRAND1,BB0001,,PRODUCT 1,74.95,Low" & @CRLF & _
"BRAND2,BB0002,,PRODUCT 2,74.95,Out of Stock" & @CRLF & _
"BRAND3,BB0003,,PRODUCT 3,74.95,Medium" & @CRLF & _
"BRAND4,BB0004,,PRODUCT 4,74.95,Low"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")