use strict;
my $str = 'Brand,Item Number,UPC,Description,RRP, Stock Level
BRAND1,BB0001,,PRODUCT 1,74.95,Low
BRAND2,BB0002,,PRODUCT 2,74.95,Out of Stock
BRAND3,BB0003,,PRODUCT 3,74.95,Medium
BRAND4,BB0004,,PRODUCT 4,74.95,Low';
my $regex = qr/(?:BRAND3|BRAND4)[^\n]+(\n|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}