import Foundation
let pattern = #"(?:BRAND3|BRAND4)[^\n]+(\n|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Brand,Item Number,UPC,Description,RRP, Stock Level
BRAND1,BB0001,,PRODUCT 1,74.95,Low
BRAND2,BB0002,,PRODUCT 2,74.95,Out of Stock
BRAND3,BB0003,,PRODUCT 3,74.95,Medium
BRAND4,BB0004,,PRODUCT 4,74.95,Low
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)