re = /(?:BRAND3|BRAND4)[^\n]+(\n|$)/
str = 'Brand,Item Number,UPC,Description,RRP, Stock Level
BRAND1,BB0001,,PRODUCT 1,74.95,Low
BRAND2,BB0002,,PRODUCT 2,74.95,Out of Stock
BRAND3,BB0003,,PRODUCT 3,74.95,Medium
BRAND4,BB0004,,PRODUCT 4,74.95,Low'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end