package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:BRAND3|BRAND4)[^\n]+(\n|$)`)
var str = `Brand,Item Number,UPC,Description,RRP, Stock Level
BRAND1,BB0001,,PRODUCT 1,74.95,Low
BRAND2,BB0002,,PRODUCT 2,74.95,Out of Stock
BRAND3,BB0003,,PRODUCT 3,74.95,Medium
BRAND4,BB0004,,PRODUCT 4,74.95,Low`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}