import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:BRAND3|BRAND4)[^\\n]+(\\n|$)";
final String string = "Brand,Item Number,UPC,Description,RRP, Stock Level\n"
+ "BRAND1,BB0001,,PRODUCT 1,74.95,Low\n"
+ "BRAND2,BB0002,,PRODUCT 2,74.95,Out of Stock\n"
+ "BRAND3,BB0003,,PRODUCT 3,74.95,Medium\n"
+ "BRAND4,BB0004,,PRODUCT 4,74.95,Low";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}