const regex = new RegExp('<img [^>]*?src=["\\\\']data:image/svg\\+xml[^>]+>', 'g')
const str = `<div>
<img class="bumbum"><img src="data:image/svg+xml,%3Csvg xmlns="http://www.w3.org/2000/svg" width="960" height="640"%3E%3C/svg%3E" />
</div>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);